logo

IT Services covering Chester, North Wales & The Wirral

Red Hill House, Hope Street, Chester, CH4 8BU


Office 330, Cheshire College, Ellesmere Port Campus Off Sutton Way, Ellesmere Port, CH65 7BF


Email: info@tst.uk.com

Phone: 01244 457870

BackupBuddy Alert

BackupBuddy Alert

If you are using the very popular WordPress plugin Backupbuddy to backup your WordPress website it is essential that you upgrade to version 8.7.5.  If your version of Backupbuddy is less than 8.7.5 you must do this urgently.  See the full announcement about Backupbuddy below:

We recently discovered a security vulnerability in our BackupBuddy plugin. The vulnerability could allow a breach to your WordPress site, so we are asking all current and expired BackupBuddy customers to confirm your sites are running version 8.7.5 or higher of the BackupBuddy plugin.

Your trust as our community and customers is of utmost importance to us, and we aim to be as honest and transparent as we can about the issue. In our effort to be as transparent as possible with this we are providing all of the details we currently know.

At this time, we have evidence that this vulnerability is being actively exploited in the wild. That’s why it’s so important to update to the latest version of the BackupBuddy plugin (8.7.5) to protect your site and ensure exposure to the vulnerability is limited. 

This security release is now available to all current and expired BackupBuddy customers so no one continues to run the vulnerable version of the BackupBuddy plugin.